给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT….这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt


输出样例:
GPLTGPLTGLTGLGLL

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#include<stdio.h>
#include<string.h>
int main()
{
const int N = 1e4+5;
char strs[N];
int gplt[4];
scanf("%s",strs);
for(int i=0;i<strlen(strs);i++)
{
if(strs[i]=='g'||strs[i]=='G')
{
gplt[0]++;
}
else if(strs[i]=='p'||strs[i]=='P')
{
gplt[1]++;
}
else if(strs[i]=='L'||strs[i]=='l')
{
gplt[2]++;
}
else if(strs[i]=='t'||strs[i]=='T')
{
gplt[3]++;
}
}
while(gplt[0]>0||gplt[1]>0||gplt[2]>0||gplt[3]>0)
{
for(int i=0;i<4;i++)
{
if(gplt[i]>0)
{
switch(i)
{
case 0:
putchar('G');
break;
case 1:
putchar('P');
break;
case 2:
putchar('L');
break;
case 3:
putchar('T');
break;

}
gplt[i]--;
}
}
}

return 0;
}